openrisc architecture · Maintained
Maintainers
- M Jonas Bonn <jonas@southpole.se>
- M Stefan Kristiansson <stefan.kristiansson@saunalahti.fi>
- M Stafford Horne <shorne@gmail.com>
Paths
- F
Documentation/arch/openrisc/ - F
Documentation/devicetree/bindings/openrisc/ - F
arch/openrisc/ - F
drivers/irqchip/irq-ompic.c - F
drivers/irqchip/irq-or1k-*
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-arch (capped at 30), ordered by date desc.
-
COLD35d
REVIEWED: 1 (1M) [PATCH v3 04/13] openrisc: Include <linux/cpumask.h> in smp.h
2026-06-05 · Boqun Feng <boqun@kernel.org> -
COLD36d
REVIEWED: 1 (1M) [PATCH v2 04/12] openrisc: Include <linux/cpumask.h> in smp.h
2026-05-26 · Boqun Feng <boqun@kernel.org> -
DORMANTno replies
[PATCH] Generate <asm/asm-offsets.h> and remove identical copies in all architectures
2026-05-19 · Ethan Nelson-Moore <hidden> -
COLD58d
REVIEWED: 1 (1M) [PATCH 04/11] openrisc: Include <linux/cpumask.h> in smp.h
2026-05-08 · Boqun Feng <boqun@kernel.org> -
STALE72d
[RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
2026-04-27 · "Christophe Leroy (CS GROUP)" <chleroy@kernel.org> -
STALE173d
[PATCH] mm/pgtable: convert pgtable_t to ptdesc pointer
2026-01-07 · alexs@kernel.org -
STALE273d
[PATCH RESEND 61/62] init: rename CONFIG_RD_LZ4 to CONFIG_INITRAMFS_DECOMPRESS_LZ4
2025-09-14 · Askar Safin <hidden> -
STALE273d
[PATCH RESEND 60/62] init: rename CONFIG_RD_LZO to CONFIG_INITRAMFS_DECOMPRESS_LZO
2025-09-14 · Askar Safin <hidden> -
STALE273d
[PATCH RESEND 59/62] init: rename CONFIG_RD_XZ to CONFIG_INITRAMFS_DECOMPRESS_XZ
2025-09-14 · Askar Safin <hidden> -
STALE273d
[PATCH RESEND 58/62] init: rename CONFIG_RD_LZMA to CONFIG_INITRAMFS_DECOMPRESS_LZMA
2025-09-14 · Askar Safin <hidden> -
STALE273d
[PATCH RESEND 57/62] init: rename CONFIG_RD_BZIP2 to CONFIG_INITRAMFS_DECOMPRESS_BZIP2
2025-09-14 · Askar Safin <hidden> -
STALE273d
[PATCH RESEND 56/62] init: rename CONFIG_RD_GZIP to CONFIG_INITRAMFS_DECOMPRESS_GZIP
2025-09-14 · Askar Safin <hidden> -
STALE273d
[PATCH RESEND 55/62] init: rename CONFIG_BLK_DEV_INITRD to CONFIG_INITRAMFS
2025-09-14 · Askar Safin <hidden> -
STALE273d
[PATCH RESEND 42/62] init: rename <linux/initrd.h> to <linux/initramfs.h>
2025-09-14 · Askar Safin <hidden> -
STALE273d
[PATCH RESEND 31/62] init: rename initrd_below_start_ok to initramfs_below_start_ok
2025-09-13 · Askar Safin <hidden> -
STALE273d
[PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
2025-09-13 · Askar Safin <hidden> -
STALE298d
[PATCH 3/6][openrisc] SET_PAGE_DIR() users had been gone since 2.3.12pre1
2025-09-11 · Al Viro <viro@zeniv.linux.org.uk> -
STALE298d
[PATCH 2/6][alpha,m68k,openrisc] PAGE_PTR() had been last used outside of arch/* in 1.1.94
2025-09-11 · Al Viro <viro@zeniv.linux.org.uk> -
STALE264d
LANDED [PATCH 10/17] openrisc: Add __attribute_const__ to ffs()-family implementations
2025-08-04 · Kees Cook <kees@kernel.org> -
STALE358d
[PATCH 1/1] uapi/termios: remove struct ktermios from uapi headers
2025-07-16 · "H. Peter Anvin" <hpa@zytor.com> -
STALE440d
[PATCH v2 03/12] mm: Call ctor/dtor for kernel PTEs
2025-04-08 · Kevin Brodsky <hidden> -
STALE460d
REVIEWED: 1 (0M) [PATCH v2 02/11] mm: Introduce a common definition of mk_pte()
2025-04-02 · "Matthew Wilcox (Oracle)" <willy@infradead.org> -
STALE473d
[PATCH 02/11] mm: Call ctor/dtor for kernel PTEs
2025-03-17 · Kevin Brodsky <hidden> -
STALE273d
[PATCH 23/41] openrisc: Replace __ASSEMBLY__ with __ASSEMBLER__ in non-uapi headers
2025-03-14 · Thomas Huth <hidden> -
STALE273d
[PATCH 22/41] openrisc: Replace __ASSEMBLY__ with __ASSEMBLER__ in uapi headers
2025-03-14 · Thomas Huth <hidden> -
STALE416d
[PATCH v2 13/13] arch, mm: make releasing of memory to page allocator more explicit
2025-03-13 · Mike Rapoport <rppt@kernel.org> -
STALE416d
[PATCH v2 10/13] arch, mm: set high_memory in free_area_init()
2025-03-13 · Mike Rapoport <rppt@kernel.org> -
STALE416d
[PATCH v2 09/13] arch, mm: set max_mapnr when allocating memory map for FLATMEM
2025-03-13 · Mike Rapoport <rppt@kernel.org> -
STALE482d
[PATCH 13/13] arch, mm: make releasing of memory to page allocator more explicit
2025-03-06 · Mike Rapoport <rppt@kernel.org> -
STALE482d
[PATCH 10/13] arch, mm: set high_memory in free_area_init()
2025-03-06 · Mike Rapoport <rppt@kernel.org>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
DORMANTno replies
[PATCH] Generate <asm/asm-offsets.h> and remove identical copies in all architectures
2026-05-19 · Ethan Nelson-Moore <hidden>